I'm also having a problem since new site came up - I have to search for pondboss and then enter via the cache site. If I enter in www.pondboss.com the old site appears and when I try to go to the forum this appears:

Content Encoding Error (content_encoding_error)

Server response could not be decoded using encoding type returned by server.
This is typically caused by a Web Site presenting a content encoding header of one type, and then encoding the data differently.

For assistance, contact your network support team.

What should I do? thanks